SAP Knowledge Base Article - Public

2692384 - Report Navigation not Working - No Report Data in Target Report

Symptom

You have created a report navigation, however after navigating to the target report, you only see the message 'No data available to display' even though there should be data.

Environment

  • SAP Business ByDesign
  • SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the work center Business Analytics, view Design Reports.
  2. Search for the target report and click on New > Report Navigation.
  3. Select a source report, enter all other required details and click on Save.
  4. Make sure the target report is assigned.
  5. Open the source report.
  6. Click on the value that you have set to be transferred (or enter a variable if you have set up a variable transfer) and navigate to the target report.
  7. You will see the message 'No report data available to display'.
  8. Close the target report and reopen it from the Design Reports view.
  9. It will show data now, even after you have made the respective changes to the view / selection.

Cause

In the report navigation, you have mapped 2 fields which are of different types. For example, you might have mapped the field Material to Material ID.

Material is of type UUID whereas Material ID is of type ID, so they cannot be used to be transferred between the source and the target report.

Resolution

Please select a different field type to be transferred to the target, so that both fields are of the same type.

Keywords

report navigation, no report data, target report, source report, analytics, reporting, field type , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem

Product

SAP Business ByDesign all versions ; SAP HYBRIS C4C CORE all versions