SAP Knowledge Base Article - Public

2690453 - Set Default Query All Does Not Reflect as Default Query in Contact Object Value Selector Screen in Opportunity

Symptom

Incorrect default query Related to Account shows in contact OVS (Object value selector) screen

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales workcenter
  2. Go to the Opportunities view
  3. Open opportunity XYZ (XYZ represents opportunity id)
  4. Go to Contacts tab
  5. Click on Add button
  6. Select any role
  7. Click on value selection of name field
  8. Default query is Related to Account
  9. Now click on advance search
  10. Click on Organize query

Here you can see default query selected All, but still default query is showing Related to Account on Contact OVS screen.

Cause

This is so designed considering the real world business use case, whenever certain documents are being created for an Account, it would be logical that Contacts from that Account would be added as involved party. Its pretty rare to involve non-related contacts in the documents.

Resolution

System behavior works as designed.

Keywords

Wrong default query, Default query All, Related to Account query, Contact tab, Opportunity , KBA , opportunity , contacts tab , default query , related to account , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer 1808 ; SAP Cloud for Customer 1811