SAP Knowledge Base Article - Public

2681771 - Tile-based Dashboards Slow Performance and Not Automatically Loading Default Filters

Symptom

  • When a user accesses a shared Tile-based Dashboard for the first time by switching to it from another Dashboard in the menu, the Dashboard just keeps loading and will not show the filters section nor the tiles.
  • The instance is not using Report Center.

Environment

SAP SuccessFactors Reporting and Analytics

Reproducing the Issue

1. Go to Analytics > Dashboards.

2. Notice that the first or default dashboard shows the filter fields for a user to make a selection and the tiles do not automatically load

3. Switch to the next Dashboard in the list.

4. Notice that the page just keeps on loading (three dots are visible), no filter fields are displayed

Cause

No default filters were selected or saved by the Admin when configuring the Tile-based Dashboard in Admin center > Manage Dashboards

Resolution

Please set default filters for the Tile-based dashboard from the Admin page or Manage Tile-Based Dashboards.  The Admin user must make sure that they navigated to the Filters tab and clicked on Save explicitly to prevent the issue.

This way the both the Dashboard and the Tiles in it should render automatically for all users when selected.  Users can then change the default filters if they need to.

 

Keywords

dashboard loads endlessly, dashboard tiles will not load, tile filters, dashboard filters, tile-based dashboard performance , KBA , LOD-SF-ANA-DSH , Dashboard and YouCalc , How To

Product

SAP SuccessFactors HCM Core 1805