SAP Knowledge Base Article - Public

2681735 - Deployment Failed After Activating PDI Solution in SDK

Symptom

Solution activation failed (Deployment Failed) after importing/uploading the solution to the target tenant.

Environment

SAP CLOUD FOR CUSTOMER

SAP BUSINESS BYDESIGN

SAP CLOUD APPLICATION STUDIO

Reproducing the Issue

  1. Login to SAP Cloud Application Studio(SDK) for the affected tenant.
  2. Open PDI Solution YPQRZMNO [YPQRZMNO is a custom PDI solution).
  3. Upload the Solution.
  4. Perform solution Activation once the solution upload is successful.
  5. Solution activation fails with below error messages.

Error Messages :-

Failed to activate items of type References to Customer-Specific Fields

Type of field PXZ does not match

Field PXZ at business object YMN, node Root does not exist

Note :-

PXZ stands for KUT extension field.

YMN stands for business object(custom/extended).

Cause

This error message occurs when you have key user extension fields (eg. PXZ, in this case) in your source tenant but not in the target tenant.

And the same extension field (eg. PXZ) is used in your PDI solution YPQRZMNO.

Resolution

You need to perform content transfer from source to target tenant, so that all the extension feilds are in sync in both the tenants.

Once the content transfer is done, you can activate the solution in the target tenant.

Keywords

SDK, C4C, BYD, Activation Failed, Error when processing class, Errors during activation of solution, Custom Solution , KBA , custom solution , deployment error , BC-DWB-REP-EXT , Extensibility , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem

Product

SAP Business ByDesign 1702 ; SAP Business ByDesign 1711 ; SAP Business ByDesign 1802 ; SAP Business ByDesign 1805 ; SAP Business ByDesign 1811 ; SAP Cloud for Customer 1302 ; SAP Cloud for Customer 1508 ; SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Customer 1802 ; SAP Cloud for Customer 1805 ; SAP Cloud for Customer 1808 ; SAP Cloud for Customer 1811 ; SAP HYBRIS C4C ADDINS 1705 ; SAP Hybris Cloud for Customer 1605 ; SAP Hybris Cloud for Customer 1608 ; SAP Hybris Cloud for Customer 1611 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711