SAP Knowledge Base Article - Public

2681354 - Translations are not Appearing in the UI after Uploading the Patch to Test or Production Tenants

Symptom

Translations which are maintained for the fields in the development tenant are not coming up in the UI of the target tenants. This happens after uploading the patch from development to other tenants(test or production).

While the translations are working fine in the development tenant UI.

Environment

SAP Cloud Application Studio

SAP Cloud for Customer

SAP Business ByDesign

Reproducing the Issue

  1. Maintain the translations in the source tenant.
  2. Upload the patch to the target tenant.
  3. You can see all the translations are transported to the target tenant successfully by checking in SDK(Right click on the solution-> Translation-> Check Status).
  4. You will go and test in the frontend UI, you can see that all the fields are not translated in the respective language. 

Cause

This issue is happened because you have used the backend text option for labelling the field in the UI designer.

Resolution

You should use only overridden text for the extension fields to ensure that the translation works fine throughout all the tenants.

  1. Open the UI Designer of the respective screen where you have maintained the translations.
  2. Select the field.
  3. Go to Properties tab.
  4. Under Text information section , select the option Label.
  5. Change the text pool from backend text to overidden text.

Keywords

Translations not working Fields not translated after upload , KBA , c4c , sdk , byd , translations not working , translations missing in patch , AP-RC-BDS-TRANSL , ByDesign Studio Translation , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer all versions