SAP Knowledge Base Article - Public

2675633 - Behaviour of Characteristic Survey Answer Date in data source Ticket Survey Answers

Symptom

You are using the standard data source Ticket Survey Answers (technical ID CODTKTSURVEYANS) and noticed that the characteristic Survey Answer Date does not contain any data.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Work Center Business Analytics, View Design Data Sources.
  2. Search for the data source Ticket Survey Answers (technical ID CODTKTSURVEYANS).
  3. Open the Preview of this data source and add Characteristic Survey Answer Date.
  4. You notice that it displays # and no actual date.

Cause

The characteristic Survey Answer Date field basically shows the answer for the date/date range type of question. In your system there is no question of type date/date range, so no answer is available. This means the characteristic Survey Answer Date will be shown # in the data source.

Resolution

If you want to see the date time at which the survey was last responded, this information can be derived from the field Survey Last Change Date Time. In case you want to see only the completed surveys, you can use the characteristic Survey Life Cycle Status.

Keywords

Survey Life Cycle Status, Survey Last Change Date Time, Survey Answer Date, Ticket Survey Answers, CODTKTSURVEYANS, no values, no data , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-LE-SUR-DEF , Survey definition = design time , How To

Product

SAP Cloud for Customer 1802 ; SAP Cloud for Customer 1805 ; SAP Cloud for Customer 1808 ; SAP Cloud for Customer 1811 ; SAP HYBRIS C4C ADDINS 1902