SAP Knowledge Base Article - Public

2674762 - DRTM Master Data Purge errors related to user's Country

Symptom

  • DRTM Master Data Purge throws one of the following errors:
    • There is no country specified for this user or user's country is not DRM enabled error
    • Country code doesn't exist or this country doesn't enable DRM. Please check picklist country or MDF country configuration for identity
    • There is no retention time defined for this country
  • Even when selecting "Ignore data retention time configuration for this purge request" the purge throws one error above

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Cause

  • "DRTM Master Data" object is not added to your instance using "Upgrade Center"
  • There is no Country specified for the user in the User Data File (UDF)
  • User's country has "Data Retention Enabled" set to 'No' in "Manage Data"
  • There is no data for Time Configuration for Country/Region-Based Data Retention available in "Manage Data"
  • Users country field is not the same as MDF country entity so there is country convert in the backend

Resolution

To use the master data purge, you need to enable the new data retention time management (DRTM) solution and the DRTM Master Data purge object and ensure that General Permission Check is completed this is for Both EC /Non EC enabled instances, please, for additional information follow the KBA 2615360:

1 .Check if the required "DRTM Master Data" purge object was added to your instance, using the Upgrade Center:

UC.PNG

2. Check if the retention time is configured for each country where it is required, using the MDF Country object.

  • Go to Admin Center > Manage Data > DRTM Master Data  > USER > Take Action > Make Correction > Add Country, timeUnit, inactivePeriod

MD.png

OBS: If you cannot find the USER(USER), please make sure the step 1 from this KBA's resolution was followed.

3. Checks to ensure that Country Field is matching MDF Country Entity: 

  1. Admin Center > Search for Manage Data
  2. Search for Country and ensure in Data Retention Enabled field the option Yes is selected;
  3. Still in Country > Click on Country Translation and place the same value that is placed in Country field
    1. For example, if in Country Field is place United States in the Country Translation you must to place United State as well

contry.PNG

4. Ask for a partner or open an case with SAP Support to check if the standard element "country" in your company whether mapping to any picklist id has been configured; 

    • For partners:
    1. Go in Provisioning > Export Data Model and check standard element "country" whether mapping to any picklist ID;
    • For Customer:
    1. Open an case mentioning this KBA with the following information:
    • CompanyID:
    • Support Access:

5. If Country is not mapped to any picklist, make sure the user's country field as shown in the image above is the same as the MDF country's default value field, provide country default value of the to be purged user and proceed with the Purge;

nonpick.png

6. If Country is mapped to a picklist ID, perform the steps below:

    1. Go to Admin Center > Picklist Management > Export all picklist.
    • If your company has complete MDF picklist migration, there is no "Picklist Management" in Admin Center, please, follow steps on 2674970 to get picklist related optionId;
    1. Find optionId of the country of the purged user;
    2. Make sure external_code was configured and external-code is equal to the country code in MDF side; 

pickimage2018-5-28_13-23-42.png

    1. Provide country related optionId of the to be purged user and proceed with the purge;

country.png

Please reference SAP Guide for further Guidance reference Data Purge

Note :

  • If Job Info Start date is in the future for the user, then you might get the error also. You will only be able to purge the user with DRTM Master Data Purge on/after the Job Info Start date
    • Go to Data Inspector -> Table_EMP_EMPLOYMENT_INFO
    • check Is EC Record is 1 for the record you are trying to purge
    • check Start Date 
    • If Is EC Record is 1 then you will only be able to purge the user on/after the Start Date that is seen on the Table_EMP_EMPLOYMENT_INFO
  • If Learning Module is enabled in your instance ensure the following permissions are granted see KBA 2675172
  • Job information should exist in employee profile for the user being purged

See Also

Keywords

DRTM, Country Code, Failed, Straight to failed, picklist, Data retention management , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-PLT , Platform Foundational Capabilities , Problem

Product

SAP SuccessFactors HCM all versions