SAP Knowledge Base Article - Public

2674398 - No Permissions Exception: Employee Replication from SAP SuccessFactors service center

Symptom

While doing the Employee Replication from SAP SuccessFactors Employee Central to SAP Hybris Cloud for Service system using SAP CPI system, you may get below error in the message monitoring of SAP CPI system.

Environment

Employee Central: Service Center

Reproducing the Issue

com.sap.it.rt.adapter.sfsf.wsclient.SfsfWsClientFaultException: Problem during invoking SuccessFactors Web service. SOAP faultCode ns2:Server, faultString SFAPI Domain Error!, errorCode NO_PERMISSIONS_EXCEPTION, errorMessage: Insufficient permissions!, cause: org.apache.cxf.binding.soap.SoapFault: SFAPI Domain Error!

14.png

Cause

Employee Central SOAP API feature and/or related permissions are missing or not granted to the correct Permission Role.

Resolution

  1. Login to SAP SuccessFactors Employee Central Provisioning account and select your company instance.
    14.png
  2. Select the Company Settings under Edit Company Settings.
  3. Under Web Services, Enable Employee Central SOAP API. Choose Save.
    14.png
  4. Logon to your SAP SuccessFactors Employee Central Company account.
  5. Search for Manage Permission Roles and Click on Super_Admin role.
  6. Click Permission.
  7. In the Permission Setting Popup, go to Employee Central API in left bar and select Employee Central Foundation SOAP API, Employee Central HRIS SOAP API, Employee Central Foundation ODATA API, Employee Central HRIS ODATA API.
    14.png
  8. Click Done.

  9. Click Save Changes.

Keywords

Employee replication in service center, NO_PERMISSIONS_EXCEPTION, errorMessage: Insufficient permissions!, ECSC, , KBA , LOD-SF-EC-SRV , EC Service Center , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors HCM Core all versions