SAP Knowledge Base Article - Public

2670749 - Automatic Process is failing - Caused by: com.plateausystems.elms.util.helper.ElmsFinderException: Can not find admin user

Symptom

Assignment Profile Synchronization APM is failing and showing this error:

java.lang.reflect.InvocationTargetException

at sun.reflect.GeneratedMethodAccessor471.invoke(Unknown Source)

...

Caused by: com.plateausystems.elms.util.helper.ElmsFinderException: Can not find admin user {adminid}

(adminid will be the ID of system administrator in your LMS)

Environment

 SuccessFactors LMS

Reproducing the Issue

In Learning Administration:

  1. Go to System Admin > Automatic Processes
  2. Open one of the Automatic Processes.
  3. Click "View Errors"

Cause

The administrator who scheduled the Automatic Process was deleted from LMS.

Resolution

Go to the Automatic Process that is failing and click the "Apply Changes" button.

This will override the last update made by the deleted admin and the APM will synchronize again.

Keywords

 automatic process, failed, status, caused by, java error, Can not find admin user

Automatic Processes

, KBA , LOD-SF-LMS-ASP , LMS AP , Problem

Product

SAP SuccessFactors Learning all versions