SAP Knowledge Base Article - Public

2667405 - Inbound E-mails Format Is Lost on Ticket Interactions

Symptom

You have noticed that some inbound e-mails are not displayed correctly on Ticket Interactions. The formatting is gone.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID XYZ (XYZ represents the affected Ticket ID).
  4. Go to the Interactions tab.
  5. See that there is inbound e-mails with coding instead of text.

Cause

We have two different behaviors here, HTML5 and RUI have different text editors and hence show the case differently.

  • HTML5:

When logged in HTML5, system will show the entire e-mail as plain text. It means that all text with HTML tags, will be shown as code and all that is text will be shown correctly.

  • RUI:

RUI does handle the HTML tags and the e-mail, in most cases, will be shown correctly. Exception is for some tags considered to be not safe, that might be removed.

Resolution

If changes to this behavior are needed urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center (servicecenter@sap.com).
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer.

To check if the e-mail contains tags that are considered not safe, you can use the SAP HTML Sanitizer. To use the tool, you need to paste the E-mail HTML file and check the Sanitize box. This will show how the e-mail should look like after the cleaning.
To get the HTML file of the e-mail you need to:

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID XYZ (XYZ represents the affected Ticket ID).
  4. Go to the Interactions tab.
  5. Select the e-mail and click on the Actions icon (the three dots one), then View Original Content.
  6. Save the file and open it on the notepad.
  7. Copy this information and paste on the SAP HTML Sanitizer.

Keywords

E-mail ; Interactions ; Ticket ; HTML ; Format ; , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer add-ins all versions