SAP Knowledge Base Article - Public

2661693 - Cancelling of Service Confirmation Not Possible Due to Error: Financial posting on fixed on date DD/MM/YYYY blocked

Symptom

You are not able to cancel a Service Confirmation due to the following error: "Posting on DD/MM/YYYY Blocked in Financial Accounting".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Field Service and Repair work center.
  2. Select the Service Confirmations view.
  3. Open service confirmation XYZ (XYZ represents the ID of the service confirmation).
  4. In the General tab enter a reason for rejection.
  5. The following error occurs: "Financial posting on fixed on date DD/MM/YYYY blocked"

Cause

When cancelling a service confirmation the system will take the same posting date for the cancellation as for the original posting when the service confirmation was released. For service confirmations this is the Fixed On date. If the Fixed On date is not maintained the system will use the Created On date as the posting date.

Resolution

To resolve this issue, you can follow either of the following option.

  • Open relevant period in financial and post the cancellation service confirmation document by following the below steps.
  1. Go to the General Ledger work center.
  2. Select the Sets of Books and Assigned Companies sub-view under Master Data view.
  3. Select the relevant company ID and choose Open and Close Period.
  4. Search for the accounting period relevant for date DD/MM/YYYY. Here you can see that the Period Status of this period is Blocked.
  5. Now select the period and choose Open Periods.
  6. Choose Save button.
  • If you do not want to open the accounting period, then you can use Set Process Control and choose to post to accounting to some other open period by following the below steps.

First you need to Set Process Control. To do so, following the below mentioned steps:

  1. Go to the General Ledger work center.
  2. Select sub-view Master Data under Companies view. Select the relevant company.
  3. Choose Set Process control.
  4. Choose Add Row.
  5. Select Process Control Status as Not Blocked, Business Process Group as 08 - Service Execution Confimation.
  6. Entry Possible Until should be the date by which you want to do the reverse confirmation. Like if you are planning to do it today, then enter today's date.
  7. From Posting Date can be same as XX/YY/ZZZZ or the date before XX/YY/ZZZZ and To posting Date can be same as XX/YY/ZZZZ  or any day after XX/YY/ZZZZ.
  8. Finally choose Save and Close button.

Now you will be able to cancel the corresponding service confirmation.
Note that it will not post into accounting yet but it will create a business task in General Ledger work center, where you need to select a new posting date for which accounting period is open. 
To do  so, follow the below mentioned steps:

  1. Go to the General Ledger work center.
  2. Select Closing Cockpit--> Closing-Relevant Tasks.
  3. Choose Advance button. In the Related Source Document, enter the service confirmation ID.
  4. Choose Go button. You will get the relevant business task for the cancellation posting in status In Process.
  5. Choose View Business Transaction button.
  6. Now choose Post to Another Period button. In the field Alternate Posting Date, enter a suitable date for which accounting period is currently open.
  7. Then choose OK button. It will take you back to the task screen. Choose Refresh button.
  8. Now the document Processing Status will change from In Process to Finished.

    With this the cancellation posting for the service confirmation will be posted to accounting with the posting date selected by you.

See Also

1523324 - Posting date in journal entry for service provision from CRM document

2869746 - In the Journal Entry from Service Confirmation, Posting Date Refers to the Fixed On Date in Service Confirmation

3168336 - Reverse Service Confirmation - Financial posting on fixed on date blocked

Keywords

Posting Date; Service Confirmation; Cancellation; Posting Period; Financial Posting; Period Blocked; , KBA , AP-SCO-SC , Service Confirmation , Problem

Product

SAP Business ByDesign all versions