SAP Knowledge Base Article - Public

2661363 - LMS - How to enable API Logging via Diagnostics

Symptom

How do we enable API Logging via Diagnostics? Engineering /Operations Team needs to collect logs while customer replicates the issue, hence the API Logging should be enabled.

Environment

SAP SuccessFactors Learning Management System

Cause

According to Engineering Team, anyone who has access to LMS Admin can access the Diagnostics page and enable this field.

Engineering Team asked me to create a KBA on this for future reference.

Resolution

1. Login to LMS native admin page

For example: https://testcustomer.plateau.com/learning/admin/nativelogin.do

2. While logged in, open a new tab and change the last part of the URL to /diagnostics

 For example:  https://testcustomer.plateau.com/learning/diagnostics

3 Click runtime configuration link: Tenant level Runtime Service Config

4. Enable the following configuration (Overridden side):

    enableAPILogging=true

Enable API.png

** NOTE: It is not recommended to have this enabled permanently. Kindly disable this after you test/replicate your issue. Let Engineering / Operations team know the exact timestamp of your replication so that they can catch the logs **

Keywords

LMS, Learning Management System, enableAPILogging, API Logging, API, Diagnostics, Tenant level Runtime Service Config , KBA , LOD-SF-LMS-ADM , Admin Tools , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning 1702 ; SAP SuccessFactors Learning 1705 ; SAP SuccessFactors Learning 1708 ; SAP SuccessFactors Learning 1711 ; SAP SuccessFactors Learning 1802 ; SAP SuccessFactors Learning 1805 ; SUCCESSFACTORS LEARNING 1808