SAP Knowledge Base Article - Public

2655986 - Generic Upsert Request Confirmation to SAP ERP HCM - error SocketTimeoutException

Symptom

You are observing the following error in your HCI artifact Generic Upsert Request Confirmation to SAP ERP HCM

  • org.apache.cxf.interceptor.Fault: Could not send Message., cause: java.net.SocketTimeoutException: Read timed out (local port xxxxx to address xxxxxx (xxxxxx.phx.od.sap.biz), remote port 443 to address xxxxxxx)

error_HCI.PNG

Environment

  • SuccessFactors HCM Suite Talent Management integration with SAP ERP HCM
  • Standard HCI package delivered by SAP (SFIHCMxx) - Add on

Cause

The timeout exceeded in your SOAP connector for the SF system. In the example below the timeout was 1 minute and the default configuration by SAP was 60000 ms (1 minute).

timeout_exceeded.PNG

Resolution

These HCI packages delivered by SAP have the edit mode available.

You can open your Design tab and edit the timeout parameter for 5 or 10 minutes instead of 1 minute (original value).

In the example below the value was changed for 10 minutes (60000 ms) and the timeout issue was solved this change + new deploy of the artifact.

change_for_10_minutes.PNG

See Also

Integration Add-On SAP ERP HCM & SuccessFactors - help webpage link = https://help.sap.com/viewer/p/SFIHCM

Keywords

  • SocketTimeoutException
  • Generic Upsert Request Confirmation to SAP ERP HCM
  • SuccessFactors HCM Suite Talent Management integration with SAP ERP HCM
  • Standard HCI package delivered by SAP (SFIHCMxx) - Add on
, KBA , LOD-SF-INT-HCI , Std. SF to 3rd Party HCI Content , LOD-SF-INT , SF Integrations - EC Payroll, Boomi/ HCI, API , PA-SFI-TM , Integration with SuccessFactors BizX Talent Management , How To

Product

SAP SuccessFactors HCM Core all versions ; integration add-on for SAP ERP HCM and SAP SuccessFactors HCM Suite all versions