SAP Knowledge Base Article - Public

2655023 - Contact Last Name Field Is Mandatory in Leads

Symptom

The Contact Last Name field is mandatory on Leads creation after the user remove the mandatory flag via Edit Master Layout.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work centre.
  2. Go to the Leads work view.
  3. Click on Adapt at right upper corner and select the option Edit Master Layout.
  4. Click on New button.
  5. Hold the mouse arrow on Contact Last Name field.
  6. Click on Change Properties (wrench icon).
  7. Deselect the check box for mandatory option.
  8. Click on Apply.
  9. Click on Adapt at right upper corner and select the option End Layout Changes.
  10. Click on New button.
  11. The field Contact Last Name keeps mandatory.

Cause

The question "Do you want to make contact for leads an optional field?" is not activated in the system's scope.

Resolution

To make the Contact Last Name field not mandatory during leads creation, the scope the question "Do you want to make contact for leads an optional field?" on Business Configuration needs to be activated as per the steps below:

  1. Go to the Business Configuration work centre.
  2. Go to the Implementation Projects work view.
  3. Click on Edit Project Scope.
  4. Click on Next button until reach the tab 4 Questions.
  5. Expand the Sales.
  6. Expand the Lead Management.
  7. Click on Leads.
  8. Flag the check box for the question "Do you want to make contact for leads an optional field?".
  9. The Contact Last Name becomes non-mandatory.

See Also

  • SAP Admin Guide - Configuring Leads
  • KBA 2718753 - The Error Message 'Last Name Missing' Triggered On Marketing Lead Creation
  • KBA 3104288 - Lead QC Error: "Save failed Last name missing"

Keywords

Leads, Contact Last Name, Field, Mandatory. , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808