SAP Knowledge Base Article - Public

2655010 - The Employee ID Field is Deactivated and Cannot Be Modified while Creating a New Employee

Symptom

When creating a new employee the field Employee ID is deactivated and you are not able to assign Employee ID.

Environment

SAP Business ByDesign

SAP Hybris Cloud for Customer

Reproducing the Issue

SAP Hybris Cloud for Customer

  1. Go to the Administrator work center.
  2. Select the General Settings view.
  3. Select the Employees link.
  4. Click on the New button.
  5. Select the Employee option.

Result: The field Employee ID is deactivated.

SAP Business ByDesign

  1. Go to the Personnel Administration work center.
  2. Select the Regular tasks view.
  3. Select the Select Country.
  4. Under Hiring, select Hire Employee.

Result: The field Employee ID is deactivated.

Cause

The system behaves according to the settings in the Business Configuration.

Resolution

In fine tuning, you have possibility to determine whether the employee ID needs to be assigned manually or it is automatically generated by the system. Only if you choose the Manual option, the Employee ID field is enabled for manual input.

You can check the configuration for the Employee ID assignment type as follows:

  1. Go to the Business Configuration work center.
  2. Select the Implementation Project view.
  3. Select the project and click on the Open Activity List button.
  4. Select the Fine-Tune tab.
  5. Search for the activity Number Ranges for Employees and Service Agents and click on the link to open the activity.
  6. Select the Number Ranges for Employees option.
  7. Under the section Intervals you can define the type as Manual.
  8. Click on Save and Close.

Keywords

Employee - Personel Administrator - Business Partner - Employee ID Field , KBA , XX-EOD-PA-PA , Personnel Administration , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions