2652518 - Products from Product Lists not Displaying in Product Survey During Simulation

SAP Knowledge Base Article - Public

2652518 - Products from Product Lists not Displaying in Product Survey During Simulation

Symptom

You have defined active products in a valid product list ABC (ABC represents the product list name).

In a product survey XYZ (XYZ represents the product survey name), you have added ABC.

However, during simulation of the XYZ, products from ABC are not displaying.

Environment

SAP Hybris Cloud for Customer.

Reproducing the Issue

  1. Go to Surveys work center view.
  2. Create a survey XYZ with Category Products.
  3. Go to Products tab, Product Lists table.
  4. Add the valid Product List ABC.
  5. Save and Activate XYZ.
  6. Click Simulation of XYZ.
  7. Products from ABC are not displaying.

Cause

During simulation we only show products that are directly added to the survey during design time. We cannot show the products that are fetched from product list because there are other criteria (e.g account ) which determines the runtime product list.

Resolution

This is system standard behavior.

Also, runtime product list determination is not supported in opportunity as of now. Our product management team will add this to the backlog for a future release.

See Also

KBA: 2534564 - Survey With Product List Doesn't Display The Products

Keywords

survey, product, product list, simulation , KBA , LOD-LE-SUR-DEF , Survey definition = design time , Problem

Product

SAP HYBRIS C4C ADDINS 1805