2652158 - Error Message: Missing channel e-mail address in recipient fields (TO or CC)

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2652158 - Error Message: Missing channel e-mail address in recipient fields (TO or CC)

Symptom

You are getting error message 'Missing channel e-mail address in recipient fields (TO or CC)' in webservice message monitoring.

Environment

HTML5 and RUI

Reproducing the Issue

  1. Go to Administrator work center
  2. Go to General settings view
  3. Click on hyperlink Web Service Message Monitoring under System Administration
  4. Select the error message id
  5. Error text: Missing channel e-mail address in recipient fields (TO or CC)

Cause

This error could indicate one of two things:

1. That the incoming email didn't have any direct recipients, i. e. all the email recipients were in BCC.
2. This email was supposed to be the channel and the admin settings are incomplete.

In both the cases, the system would reject the incoming email with the
error: Missing channel e-mail address in recipient fields (TO or CC)

Resolution

If it is the second case then need to maintain the channel and then the message can be restart from backend. In this case create an ncident.

If it is the first case then the message should be cancelled.

Keywords

Missing channel e-mail address in recipient fields (TO or CC), webservice message monitoring. , KBA , incoming error message , webservice message monitoring , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem

Product

SAP Hybris Cloud for Customer all versions