2645470 - Keyword word search not possible in Candidate search

SAP Knowledge Base Article - Public

2645470 - Keyword word search not possible in Candidate search

Symptom

This article describes the root cause for keyword tag not appearing in Candidate Search.

Environment

 SuccessFactors Recruiting Management (RCM) - All versions

Reproducing the Issue

Step 1. Go to Recruiting.

Step 2. Go to Candidates Tab.

Step 3. When you go to Candidate Search, you will not find the keyword tag or have the ability to search keywords in the resume or coverletter.

Problematic instance:

2018-05-18 18_19_23-search_keyword2.png &#x200E&#x3b;- Photos.png

Expected Behaviour:

2018-05-18 18_18_34-search_keyword.png &#x200E&#x3b;- Photos.png

Cause

In your Candidate Profile template, either the resume field or coverLetter field is marked as sensitive="true."

This is what it looks like in Manage Templates:

2645470_kba.png

Sample code setup:

 <field-definition id="resume" type="richText" required="true" custom="false" anonymize="true" sensitive="true">
 <field-definition id="coverLetter" type="richText" required="false" custom="false" anonymize="true" sensitive="true">

Resolution

Edit the Candidate Profile and set both the resume field and coverLetter field to sensitive="false."

See Also

KBA 2556844 - New Tag for identifying sensitive personal Data (SPD) - RCM

Keywords

Sensitive Tag, Candidate Profile, Keyword Search , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors HCM Core 1802