SAP Knowledge Base Article - Public

2642080 - 'My Accounts' and 'My Accounts With No Visits Planned' in Visit Planner

Symptom

You are in the Visit Planner, using the 'My Accounts With No Visits Planned' search query and you are not seeing the expected results.

You also want to know which accounts to expect under the 'My Accounts' query.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visits work center.
  2. Select the Visit Planner view.
  3. In the search query dropdown menu, select  'My Accounts With No Visits Planned'.
  4. Then select the query 'My Accounts With No Visits Planned'.

The accounts presented in the screen do not match your expectations. For example, accounts that have no visits at all are shown for the  'My Accounts With No Visits Planned'.

Cause

The logic behind the  'My Accounts With No Visits Planned' query will select:

  • Accounts without a Last Visit and without a Next Visit; this means accounts that have not been visited at all.
  • Accounts where the Visit Before Date is within the past.
  • Accounts without a Visit Before Date and where the Next Visit lies within the past.

The logic behind the 'My Accounts' query in the Visit Planner view are:

  • All accounts where you are part of the account team or territory team.
  • It does not include sub territories where the accounts belong to.

Resolution

This is the current system standard behavior.

If you need changes in the behavior of this standard query, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by the Cloud Service Center on https://www.sap.com/services/application-development.html .

You can contact the Cloud Service Center as follows:

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influence Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer

See Also

KBA: 2543477 - Filter My Accounts Shows All Accounts In Users Territory, Even Those For Which He Is Not Part of the Account Team

Keywords

Visit Planner, Visit, My Accounts With No Visits PlannedAccount, My Accounts , KBA , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions