2640704 - Home Page: ToDo > Approvals tile is missing after 1805 release

SAP Knowledge Base Article - Public

2640704 - Home Page: ToDo > Approvals tile is missing after 1805 release

Symptom

After the 1805 release, the "Approvals" tile is now missing from the Home Page, for users who have pending workflows to approve

MissingToDo_Approvals.jpg

Environment

  • Employee Central
  • Platform
  • 1805

Reproducing the Issue

Employee Central is enabled:

  1. Navigate to the Home Page
  2. The "Approvals" tile is missing

Employee Central is not enabled:

  1. Navigate to Home Page
  2. The ToDo section is missing entirely

Cause

1805 release defect.

The following feature/permission checks were added and are now causing this issue.

To see the ToDo section AND the Approvals tile, the following must be enabled/granted (please note that these permission checks will be removed via PTCH-27855 - targeted for May 19th, 2018).

  1. Feature - Employee Central V2 is enabled
  2. Permission - Admin access to OData API
  3. Permission - Manage Workflow Request

If these permissions are granted and EC is enabled, then you will see the Approvals tile - Please note that you should not grant these admin permissions to regular users (Admin access to OData API & Manage Workflow Request).

Resolution

Currently the "Approvals" tile is missing from the ToDo section of the Home Page.

For EC customers, if the end user is an Admin user (or such) and are granted with the following permissions, then they will see the Approvals tile. Please note that these are both very powerful permissions that will allow Admins to access any EC data via OData API as well as be able to view any Workflow and edit the approval chain.

  1. Permission - Admin access to OData API
  2. Permission - Manage Workflow Request

It is recommended that instead of granting any users these permissions (above), please instead provide the work-around as given below, which does not require granting any admin level permissions.

Permanent Fix:

The fix (PTCH-27855) will be deployed to 1805 instances on May 19th, 2018.

Work-around:

  • Via Action Search
  1. If you have Action Search enabled, in the Action Search bar, type "View My Pending Requests" and select the same in the list returned
  2. You can approve pending workflows from this UI
  • Via Manage Pending Requests tile
  1. Navigate to Admin Center > Manage Home Page
  2. Enable the "Manage Pending Requests" tile for all users
  3. Click the "Edit" pencil on the right
  4. Click on "Navigation" step
  5. Set "Tile Target" to "URL"
  6. Specify the URL as "https://salesdemo4.successfactors.com/xi/ui/ect/pages/pendingWorkflows/pendingWorkflowV12.xhtml?" but ensure you replace the highlighted part of the URL with the relevant URL for your instance (this deep link depends on which Data Center your instane is located on).
  7. Click "Next"
  8. Click "Finish"
  9. Scroll down and click "Save"
  10. Users will then see the "Manage Pending Requests" tile on their Home Page, and can click the link to be redirected to "View My Pending Requests"

 

Permissions:

If not already granted, the End User will need permissions granted to the following View, in order to navigate to the page:

  1. Admin Center > Manage Permission Roles
  2. Select the Role to update
  3. Click "Permissions..."
  4. Under "Employee Views" grant permission to "Pending Requests"

PendingRequestsPermission.jpg

Keywords

1805, ToDo, Approvals, Tile, Home Page, ECT-98412, UI-14961, PTCH-27855 , KBA , LOD-SF-EC-WFL , Workflow & Trigger (Rules & XML) , LOD-SF-PLT-HOM , Home Page , Bug Filed

Product

SAP SuccessFactors HCM Core 1805