SAP Knowledge Base Article - Public

2638544 - The Workflow Rule to Trigger The Action Assign me as Owner Does Not Work as Expected

Symptom

The Workflow Rule to trigger the action Assign me as Owner on Account creation does not work as expected.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

Prequiste : Configure the below workflow rule

  1. Go to the Administrator work center.
  2. Go to the Workflow Rules view.
  3. Select the New button.
  4. Enter a value in the Description field.
  5. Choose Account from the Business Object field.
  6. In the timing field, select On Create Only.
  7. Select Next.
  8. Select the Add Groups button.
  9. Choose Role Equal to value Prospect.
  10. Select Next.
  11. In the Rule Type field select Action.
  12. Choose Assign Me as Owner in the Select Action field.
  13. Select Next.
  14. Activate and Finish.

Create an Account:

  1. Go to the Customers work center.
  2. Go to the Accouts view.
  3. Select the New button.
  4. Choose Prospect from the Role field.
  5. In the Owner field select another user.
  6. Select Save and Open.
  7. The Owner does not get assigned to you on Account creation.

Cause

This is the expected behaviour. The workflow rule enters the Owner only if the field is left blank on Account creation.

Resolution

This workflow rule works as designed.

Keywords

KBA , workflow rule , assign me as owner , account , action , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions