SAP Knowledge Base Article - Public

2638035 - Enabling Data Retention Management Purge - Onboarding 1.0

Symptom

This KBA explains how to enable Data Retention Management Onboarding Purge and covers:

  • Prerequisites
  • Creating a DRTM Onboarding Purge Requests
  • Approving a DRTM Onboarding Purge Requests

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding 1.0

Cause

Compliance for EU General Data Protection Regulation (GDPR)

Resolution

Prerequisites

  • DRTM Onboarding (Upgrade Center)
  • Manage Data Purge (Manage Permission Roles)
  • DRTM Master Data (Manage Permission Roles)
  • DRTM Onboarding Candidate Info (Manage Permission Roles)
  • Data Retention Enabled (Country in Manage Data)
  • DRTM Onboarding Candidate Info (Retention Time Configuration in Manage Data)

DRTM Onboarding (Upgrade Center)

  1. Navigate to Admin Center > Upgrade Center
  2. Find DRTM Onboarding under Optional Upgrades
  3. Click Upgrade button to add the feature in the system

    screenshot0045_ 10272018014151.png

Note: Company System and Logo Settings is required when enabling DRTM Onboarding

Manage Data Purge (Manage Permission Roles)

  1. Navigate to Admin Center > Manage Permission Roles
  2. Select role to grant permission to data purge
  3. Under Permission settings > Administrator Permissions > Manage Data Purge, grant role with Create Data Purge Request and Create DRTM Data Purge Request
  4. Under Permission settings > Administrator Permissions > Manage Data Purge, grant role with Approve DRTM Data Purge Request and Approve DRTM Data Purge Request
  5. Click Done and Save Changes for action to reflect in the system

    screenshot0047_ 10272018033625.png

DRTM Master Data and DRTM Onboarding Candidate Info (Manage Permission Roles)

  1. Navigate Admin Center > Manage Permission Roles
  2. Select role to grant permission to DRTM Onboarding Candidate Info
  3. Under Permission settings > User Permissions > Data Retention Management
  4. Find DRTM Onboarding Candidate Info and grant all permissions (Visibility and Action)
  5. Click Done and Save Changes for action to reflect in the system

    screenshot0044_ 10272018013457.png

Data Retention Enabled (Country in Manage Data)

  1. Navigate to Admin Center > Manage Data
  2. Search object Country and select the country where purge is needed (e.g. USA)
  3. If Data Retention Enabled is set to No, select the Take Action drop-down and click Make Correction
  4. In the field Data Retention Enabled, select Yes
  5. Click Save for action to reflect in the system

    screenshot0046_ 10272018033039.png

Note: By default Data Retention Enabled value is No

DRTM Onboarding Candidate Info (Retention Time Configuration in Manage Data)

  1. Navigate to Admin Center > Manage Data
  2. Search object DRTM Onboarding Candidate Info and select CANDIDATE_INFO (CANDIDATE_INFO...
  3. The country with Data Retention Enabled equals to Yes should be added in Retention Time Configuration table
  4. In addition, Time Unit should be configured and value of Past Start Date

    e.g. If 1 is selected in Past Start Date and Time Unit as a month, the candidate with hiredate that is past 1 month will be purged.

  5. Click Save for action to reflect in the system

    screenshot0048_ 10272018033925.png

Create a DRTM Onboarding Purge Request

  1. Navigate to Admin Center > Company Setting > Data Retention Management
  2. Click Create New Purge Request and Select a purge request type (DRTM Onboarding Purge)
  3. Name the purge request and Define Purge Rule (Select a single user, Select multiple users, or Multiple lists of Users)
  4. Add approvers; and
  5. Schedule or launch request

    screenshot0050_ 10272018044829.png

Approve a DRTM Onboarding Purge Request

  1. Navigate to Admin Center > Company Setting > Purge Request Monitor
  2. Under Requests Pending Approval tab, locate the request to approve or decline

    screenshot0053_ 10272018044902.png

  3. Once approval is given, approval will transfer to Approved Requests
  4. Monitor the status if completed or failed

    screenshot0055_ 10272018044916.png

Reminders

  • The Form I9 Company Level assigned to the process is where the country populated for the candidate or employee
  • If the Form I9 Company Level assigned to the process is Level 1, follow the steps below
    1. Navigate  SAP SuccessFactors HXM > Onboarding > Reference Files > Corporate Structure
    2. Select the level where Form I9 Company Level is assigned to a process
    3. Ensure that each item have value in the country field
  • Data Retention Enabled (Country in Manage Data) should be yes to the country of candidates where purge is needed
  • When purging, OnboardingCandidateInfo (OCI) will be deleted with the activity workflow

Keywords

SF, Success, factors, OBD, ONB, Onboarding, GDPR, EU, Data, Protection, Purge, User, Retention, Request, Monitor , KBA , #sfobddrtm , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , LOD-SF-PLT-DRM , Data Retention Management , How To

Product

SAP SuccessFactors Onboarding all versions