SAP Knowledge Base Article - Public

2636102 - LMS - Users who Self-Register in a Scheduled Offering does not receive Registration Notifications

Symptom

Users who Self-Register in a Scheduled Offering does not receive Registration Notifications, but if Admin registers user, the notification is sent. Why is the notification not triggered when Scheduled Offering is Self-Registered?

Environment

SAP Successfactors Learning Management System

Reproducing the Issue

1. Login as user

2. Search for a Scheduled Offering on the Catalog

3. Self-Register on the Scheduled Offering

4. Registration Notification is not triggered.

** Note that this does not happen when the Scheduled Offering is assigned directly by an admin **

Cause

There is no email address populated under

System Admin -->Configuration --> Global Variables --> Mail --> User Notification Email

Resolution

As per Engineering:

The User Notification Email (System Admin -->Configuration --> Global Variables --> Mail --> User Notification Email is primarily used as "From" email address for user SO notifications. 

If this is not populated, then the "User Notifications" will not be triggered for Self-Assigned / User Assigned Scheduled Offerings. 

The Notification is triggered for admin-assignments because the Admin Notification Email is populated.

Keywords

 LMS, Learning Management System, Notification, Scheduled Offering Notification, Notification is not triggered, Not Triggered, Email, Registration, Registration Notification, Registration Notification is not Triggered, Self-Registration, Self-Assign, User assign, admin assign , KBA , LOD-SF-LMS-NOT , Notifications , Problem

Product

SAP SuccessFactors Learning 1611 ; SAP SuccessFactors Learning 1702 ; SAP SuccessFactors Learning 1705 ; SAP SuccessFactors Learning 1708 ; SAP SuccessFactors Learning 1711 ; SAP SuccessFactors Learning 1802 ; SAP SuccessFactors Learning 1805