2630831 - Error Message There is an Activation in Process for Solution While Activating PDI Solution From SDK

SAP Knowledge Base Article - Public

2630831 - Error Message There is an Activation in Process for Solution While Activating PDI Solution From SDK

Symptom

You will receive server message while activating custom solution from SAP Cloud Application Studio.

Environment

SAP Cloud Application Studio

Cloud for Customer

Business Bydesign

Reproducing the Issue

  1. Log in to SAP Cloud Application Studio.
  2. Open PDI solution YMNOP123 [ Where YMNOP123 is a PDI custom solution]
  3. Open Implementation Manager
  4. Click on Activate

Error Message - There is an activation in process for solution YMNOP123_

                         Try again later.

CD.png

Cause

This error message will appear when the solution activation is already triggered in the system and running in background mode.

Resolution

You are not allowed to perform any SDK changes on the solution while activation is running and also you cannot re-trigger the activation.

This is expected error message.

See Also

You have to wait for solution activation to finish to perform further changes on the solution.

Keywords

SDK, Activation, PDI solution, custom solution, activation in process, Cloud application studio, Server Messages , KBA , AP-RC-BDS-1O , ByDesign Studio OneOffs , Problem

Product

SAP Cloud for Customer 1211 ; SAP Cloud for Customer 1302 ; SAP Cloud for Customer 1305 ; SAP Cloud for Customer 1308 ; SAP Cloud for Customer 1311 ; SAP Cloud for Customer 1402 ; SAP Cloud for Customer 1405 ; SAP Cloud for Customer 1408 ; SAP Cloud for Customer 1411 ; SAP Cloud for Customer 1502 ; SAP Cloud for Customer 1505 ; SAP Cloud for Customer 1508 ; SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Sales 3.0 ; SAP HYBRIS C4C 1705 ; SAP HYBRIS C4C 1802 ; SAP HYBRIS C4C 1805 ; SAP HYBRIS C4C 1808 ; SAP Hybris Cloud for Customer 1605 ; SAP Hybris Cloud for Customer 1608 ; SAP Hybris Cloud for Customer 1611 ; SAP Hybris Cloud for Customer 1702 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711 ; SAP Sales OnDemand 1.0 ; SAP Sales OnDemand 2.0 ; SAP Sales OnDemand 4.0