Symptom
You are approving an opportunity/sales quote by e-mail; you do not see your name in the Approver column of the Approval view. When you approve it via notification inside the system your name gets displayed correctly.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Open the Opportunity/Sales Quote view.
- Open the Opportunity/Sales Quote ABC (where ABC stands as Opportunity/Sales Quote ID).
- Click in the Actions button in the lower menu bar.
- Select Submit for Approval.
- Check the e-mail sent for the relevant approver.
- Approve the Oppotunity/Sales Quote ABC using the hyperlink displayed in the e-mail.
- Open the Opportunity/Sales Quote ABC again.
- Select the Approval view.
You notice that the Approver column is blank; you expected to see your name on it.
Cause
When approving by e-mail, the system triggers the status update via system user (SAP_SMTP_IN). The technical user does not have a person data maintained and hence it does not fill the approver column as expected.
Resolution
The functionality of displaying the name of the approver in e-mail approving scenarios is planned to be made available in a higher release. At this point in time, we are not in a position to provide more accurate information on date and/or timelines for this future release.
If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center (servicecenter@sap.com).
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influence Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer
Keywords
Approver Sales Quote Opportunity Approval by E-mail , KBA , LOD-LE-CQP , Customer Quote Processing , Product Enhancement