2612425 - LMS: Cannot Log in to LMS via BIZX after Refresh

SAP Knowledge Base Article - Public

2612425 - LMS: Cannot Log in to LMS via BIZX after Refresh

Symptom

  •  LMS refresh completed
  • Cannot login to LMS via BIZX after refresh

Environment

SAP Successfactors Learning Management System (LMS)

Reproducing the Issue

  1. Log in to BIZX.
  2. From the 'Home' drop-down, select 'Learning'. (Sometimes, label is changed to 'Academy', ect...)
  3. User is redirected to a BIZX Production log in page instead of LMS homepage.

Cause

The following values are not changed in the BIZX configuration file. (LMS Admin > System Admin > Configuration > System Configuration > BIZX)

baseURL=

successFactorsCompanyID=

metadataProviders[IDP1].value=

These values are still pointing to the source instance (normally Production), hence users get redirected to BIZX Production log in page.

Note: This is an expected issue that happens after refresh. Refresh activity copies ALL data from the source system, including integration configurations. Hence, administrators are always reminded to have a back-up of configuration files before refresh, then copy them again after refresh. See Before and After Refresh activity in KBA 2165346 - LMS Refresh Request process.

Resolution

If you have backed-up the configuration file before refresh, copy and paste it to the BIZX configuration file.

If not, update the values below.

Value Example
baseURL= https://performancemanager4.successfactors.com
successFactorsCompanyID= CompanyID
metadataProviders[IDP1].value= https://performancemanager4.successfactors.com/idp/samlmetadata?company=CompanyID

Keywords

 login, log in, BIZX, Successfactors, refresh, error, page, baseURL, CompanyID, Company ID, URL, LMS, Learning , KBA , LOD-SF-LMS-INT , LMS Integrations , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions