2611222 - All About Transfer Logs Facet In C4C Sales Quote and Order

SAP Knowledge Base Article - Public

2611222 - All About Transfer Logs Facet In C4C Sales Quote and Order

Symptom

You see "Transfer Logs" facet in Sales Quote/ Sales Order is not filled or is missing

Environment

SAP Hybris Cloud For Customer

Reproducing the Issue

Scenario 1 :

1) You open the Sales Quote
2) Try to find the facet "Transfer Logs"
3) You find the facet itself is missing

Scenario 2:

1) You open the Sales Quote / Sales Order
2) Open the facet "Transfer Logs"
3) You see the log is empty

Cause

Scenario 1 : Transfer Logs facet will not be shown for Quote Follow-up scenario. The facet is available only when Bi-Directional Quote replication is enabled

Scenario 2 : Transfer Logs will be filled only when there is an error during the transfer process.

Resolution

Quote => Order (Follow-up document creation)

1) Once you trigger the Follow-up document creation request(typically using Submit/ Create External Follow-up Document), the field "" will be set to "In Process" from "Not Started"
2) Then if you find the Idoc in external system is failed for any reason - we will always suggest you correct this in ERP
3) If a situation arises that the correction needs to be done in C4C , then after the correction you have to initiate the transfer process again.
4) As you dont have an option to revoke the transfer status for this scenario, please contact SAP Support via Incident or using "Expert Chat" to get the status revoked.

Quote => Quote and Order => Order Replication

1) Once you trigger the transfer status(typically use the action "Transfer" ) , the field "Transfer Status" on quote/order header will set to "In Process" from "Not Started"
2) Transfer logs are provided to ensure that the user will be able to check the logs if the process is interrupted with any issue once it is initiated.
3) If the logs are filled and you understand the reason for failure - after correcting the data you can click on cog wheel icon in the Transfer Logs facet and use the action "Revoke Transfer Status" so that Transfer status will be set to "Not Started" 
4) Then you can re-initiate the transfer process starting from Step1

Keywords

C4C Transfer Logs; Transfer Logs on C4C Sales Quote; Transfer Logs on C4C Sales Order; Transfer Status; C4C Transfer Status; Transfer status on C4C Sales Quote; Transfer Status on C4C Sales Order , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-INT-CRM , Integration of C4C with CRM , Problem

Product

SAP HYBRIS C4C 1705 ; SAP HYBRIS C4C 1802 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711