SAP Knowledge Base Article - Public

2610639 - Branding Template Not Generated When Replying To An E-mail

Symptom

You set up a branding template for your e-mail channels. When you choose to compose and send a new e-mail the recipient receives the e-mail and can see the branding template. However, when you click on Reply to an e-mail instead of composing a new e-mail, the branding template is not added to the bottom of your reply. Instead, it is added to the very end of the entire email thread that is received by the recipient.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center in the HTML5 client.
  2. Go to the Tickets view.
  3. Open any ticket.
  4. In the Overview facet, under the Interactions tab click on Reply.
  5. The reply has no branding template below the latest message, instead the branding template is displayed at the very end of the email thread.

Cause

This is standard behavior.

Resolution

This functionality will be added in a future release. As a workaround, you can use response templates for text based signatures. You can also create a custom text field as signature and include that in the response template. Please note: Only text fields are supported in this scenario.

Keywords

branding template; compose e-mail; reply; e-mail channel , KBA , reply , e-mail channel , branding template , compose e-mail , LOD-CRM-PM-SRV , C4C Product Management - Service , Problem

Product

SAP Cloud for Customer add-ins all versions