2605461 - Ad Hoc Reports Missing Data for Some Columns

SAP Knowledge Base Article - Public

2605461 - Ad Hoc Reports Missing Data for Some Columns

Symptom

There is no data pulling through for some fields in job info for any schema I have tried in ad hoc

  • Job Information (date range)
  • Person and employment (as of date)
  • Person and employment export

Environment

Employee Central – Ad Hoc Reports

Reproducing the Issue

1. Reporting

2. New > Report – Table > Select Domain

3. Person and Employment as of date Report

4. Choose columns like company and job family

5. Run the report both offline and online

6. No data appears

Cause

This is caused by an MDF caching and data replication problem

Resolution

The data needs to refresh in the MDF cache for it to replicate correctly for these objects to both Ad Hoc report servers, online and offline servers, we need to do the following

For the company field not showing data, do the following:

1. Admin Centre > Configure Object Definitions

2. Legal Entity > add a new custom field > data type must be string > and save the object

3. Then try the report again and the data will now appear in the reports

4. Remove the field after testing if the data appears in the reports

If this happens for other fields, then go to manage business configuration and check what objects the fields refer to and then do as stated above

If the field has an association, do the same with that object as well

Keywords

Ad Hoc, Data Missing, Person and Employment as of Date, Job Information (Date Range), Ad Hoc Reporting, Job Information, Associated Data, MDF data, Configure Object Definition, ECT-90970, Ad hoc Reports Missing Information , KBA , LOD-SF-EC-REP , Reporting Data , Problem

Product

SAP SuccessFactors HCM Core 1711