SAP Knowledge Base Article - Public

2601474 - Users do not Have Access to the Canvas Report on Report Center - Online Report Designer

Symptom

Users do not have access to the Canvas Report even though the permissions are set for to be controlled by RBP on the Manage Workforce Analytics.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Workforce Analytics

Reproducing the Issue

  1. Access the reporting tab. 
  2. On Report Center select new and the section below where the Report - Canvas in red is not available.
    canvas.png

Cause

This is happening because the option to use the RBP permissions over the Analytics role is enabled, but is not refreshed.

Resolution

  1. Go to "Manage Workforce Analytics" under Admin Center > Reporting and Analytics;
  2. Disable "Functional and Option Permissions" and select save;
  3. Enable the option again and save;
  4. Log out of the instance ;
  5. Clear the cache and Log in again.

The behavior should be as expected now.

See Also

2542140 - User is unable to access / create 'Report - Canvas' reports, in-spite of having required permissions.

Keywords

Canvas report not visible - not appearing - Manage Workforce analytics RBP permission ORD not working Functional Option - User is not able to see canvas report , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors Workforce Analytics all versions