SAP Knowledge Base Article - Public

2601119 - LMS Integration error "This page can't be displayed" when entering LMS via BizX

Symptom

When accessing Learning via Bizx, a user gets the error message "This page can't be displayed" as outlined below:

error_message_page.png

But there are no errors when access Learning Administration.

Environment

SuccessFactors Learning Management System (LMS) - All Supported Versions

Reproducing the Issue

  1. Log into BIZX
  2. Navigate to Learning from Home
  3. Error appears

Cause

This occurs after SSO was removed from the LMS instance to allow integration with BizX.

The settings that require changing in the LMS > System Admin > Configuation > System Configuration > Authentification were not changed accordingly.

Resolution

In the LMS navigate to System Admin > Configuation > System Configuration > Authentification and update:

loginURI.USER=/user/ssoLogin.do to loginURI.USER=/user/login.do

And change the following settings from false to true:

excludedFilterURIs.USER[/user/login.do]=true
excludedFilterURIs.USER[/user/login.jsp]=true
excludedFilterURIs.USER[/user/site/logout.do]=true
excludedFilterURIs.USER[/user/ssoLogin.do]=true

In case, after the change also it's still not working, a Customer Support ticket may be required to request a restart of the tenant.

See Also

2446475 - How to Integrate LMS with HCM Suite (BizX) and troubleshoot errors - Guided Answer

2320437 - SSO errors when configuring BizX to LMS Integration

Keywords

This page can't be displayed, LMS, BizX, SSO, Learning access, Authentification, loginURI.USER, excludedFilterURIs.USER , KBA , LOD-SF-LMS-INT , LMS Integrations , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors Learning all versions