2595176 - User enrolled in Scheduled Offering with an approval process and immediately received a notification informing the request was approved

SAP Knowledge Base Article - Public

2595176 - User enrolled in Scheduled Offering with an approval process and immediately received a notification informing the request was approved

Symptom

A user self-registered in a Scheduled Offering that has an approval process configured and immediately received a notification informing that the request was approved, without the supervisor approving the request.

The supervisor received a notification informing that the user requested approval for the Scheduled Offering, but the user received a notification saying the request was already approved.

Environment

SuccessFactors LMS

Reproducing the Issue

  1. As a user, self-register into a Scheduled Offering (or any course that has an Approval Process configured)
  2. The supervisor will receive a notification saying that an approval is required, while the user will receive a notification saying the approval was already granted.

Cause

The Notification Template ID ApprovalProcessInitialRequest was wrongly customized to say the request has been approved.

Resolution

  1. Go to System Admin > Configuration > Notification Templates
  2. Search for Template ID ApprovalProcessInitialRequest and edit it.
  3. Look for the inconsistency and modify the template body.

Keywords

approval process, notification, ApprovalProcessInitialRequest, template
, KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-TAP , LMS Approvals , Problem

Product

SAP SuccessFactors Learning all versions