SAP Knowledge Base Article - Public

2588838 - Changes to Requested On Date in a Service Order do not Save.

Symptom

When changing the Requested On date in a service order, the system does not save the changes but reverts back to the original date.

 

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders Work Centre.
  2. Go to the Service Order Processing View.
  3. Show All Orders and enter XXX in the Find Field. (XXX represents the ID of the Service Order).
  4. Navigate to the General Tab.
  5. Change the Requested On date to another date in the future.
  6. Click Save. 
  7. The system automatically reverts back to the original date.

Cause

The manual change of the Requested On date in the service order does not automatically change the Requested End date. This is because the automatic computation is done only if both the dates are defaulted by the system. If one date is manually changed, the system cannot determine which one of the dates it has to adjust. Therefore, it reverts back to the last correct date.

Resolution

  1. Go to the Service Orders Work Centre.
  2. Go to the Service Order Processing View.
  3. Show All Orders and enter XXX in the Find Field. (XXX represents the ID of the Service Order).
  4. Click on View All.
  5. Navigate to the General Tab. And navigate to Main information Tab.
  6. When changing the Requested On date to a date in the future, also manually adjust the Requested End date to a date after the Requested On date. The changes can then be saved.

Keywords

Service Order. Requested On date. , KBA , service order , change , requested on date , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign 1711