SAP Knowledge Base Article - Public

2585706 - Solution is in Disabled Status in the Solution Explorer

Symptom

You are trying to make changes to your custom solution as it is in the status 'Disabled' in the Solution Explorer, even though you can see it is 'Enabled' and 'In Development' status in the Implementation Manager.

Environment

  • Cloud Application Studio (All versions of the SDK).

Reproducing the Issue

  1. Open the Cloud Application Studio (SDK).
  2. Open the affected custom solution.
  3. Select View.
  4. Select 'Implementation Manager'.
  5. Note that the status is 'In Development'.
  6. Note that the Solution Enablement is Enabled.
  7. Select View.
  8. Select 'Solution Explorer'.
  9. Note that the status is 'Disabled'

DISABLED.png

Cause

If the same solution exists in more than one tenant, on the same physical System (both tenants have the same System ID), and the solution is in the 'In Development' status in both of these tenants, then one of the tenants solutions are Disabled by default.

Resolution

1. Delete the affected custom solution from either one of the tenants on the system.

OR

2. Request for 'Immediate' deletion of one of the test tenants, in which development is not required for that test tenant.

See Also

2171346 - Message: Development of Solution &1 Not Permitted as Long as Backup Tenant Exists

 

Keywords

Disabled, Implementation Manager, SDK, PDI, Edit, Solution , KBA , sdk , status , disabled , solution , implementation manager , edit solution , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , Problem

Product

SAP Cloud Applications Studio all versions