SAP Knowledge Base Article - Public

2585476 - Workflow Rule Does Not Consider The Contact Permission Field

Symptom

You have a Workflow Rule that sends an e-mail to the Contact ID ABC (ABC represents the ID of the contact), however, the Workflow Rule is sending the e-mail even when the Contact Permission field inside Contacts is set to "Disallowed".

Environment

SAP Cloud for Customer

Cause

The Workflow Rule engine does not have a check in the field Contact Permission.

Resolution

This is the system behavior of SAP Cloud for Customer, the Workflow does not have a validation based on this field.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:

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  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Hybris Cloud for Customer Influence Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

Workflow Rules; Contact Permission; Disallowed; Allowed; Check Permission; Automatic Replies. , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions