SAP Knowledge Base Article - Public

2584658 - How to Check if a User is an EC User Using the Integration Center - isECRecord Boolean

Symptom

When a user is created via imports, if the import files are not carried out in the correct order, this can cause the user to not be stored correctly as an Employee Central employee.

This can cause various issues through the system:
 • 2092931 - Employee Central: Some users do not Synchronize via HRIS Sync and do not appear in Ad Hoc and ORD Reports (IS_EC_SYSTEM_OF_RECORD)
 • 2319432 - Few users' records are present in "Personal Information" but are missing in "Global Job Information".
 • 2366537 - Employee Central views no longer available in My Employee Files for some users

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite

Reproducing the Issue

The issue will occur for a single or small population of users - where other users data will synchronize without issue

Full HRIS Sync does not solve the problem with the few users that do not synchronize.

  1. Edit EC data for an employee (with effective date of today or in the past) and save the change. The HRIS Sync should then synchronize to Employee Profile
  2. Once the change is made the data did not synchronize to Employee Profile

Cause

  • If you experience on of the above issues or would like to check if a user is an EC user, this can be done via the Integration Center.
  • If a user is an EC User they will have the value "true" maintained for the system field "isECRecord".
  • If a user was not correctly created as an EC user they will have no value maintained for this field.

Resolution

You can use the Integration Centre to check what value is maintained for the field for the impacted user. If you do not have the Integration Center, you can deploy it in your instance from the Upgrade Center. (Note - please follow the instructions in Upgrade Center to deploy this Admin Tool).

Please note: this field is designed to be visible for admins. Only users with Employee Central HRIS OData API (read-only) permission can see this property.

Steps to identify whether a user is an EC user or not

1. In Admin Centre Navigate to Company Settings and select Integration Centre.

2. On the home page select "My Integrations":


    1.jpg


3. Here on the right-hand side you can create a new integration by selecting the Create button, in the drop-down select "Scheduled Simple File Output Integration":


    2.jpg


4. In the "Search for Entities by Entity Name field, search for Employment Details and then select Employment Details from the left panel:


     3.jpg


     
5. This will return employment details field to filter on. Select the field "isECRecord Boolean" and then "Select" button on the bottom right:


     4.jpg


6. On the following page there are tabs, similar to what is seen in Ad Hoc Reports.
     Here you can filter for a certain user or search for all non EC Users by using the "Filter and Sort" tab. - Select "Advanced Filters" here you can define your filter criteria: 
     - To search for a specific user, select :   
        Field =  Person ID External or User Id
        Operation = is equal to
        Value = Enter the users Person Id or User ID:


        51.jpg


     - To search for all none EC users, select:   
       Field = isECRecord
       Operation = is not equal to
       Value = true:


       5.jpg


7. On the "Configuration Fields" tab, you will see a preview of the data, similar to the preview pane in Ad Hoc reporting. 
     In the below screenshot you can see the example user being checked has no value maintained in the "isECRecord" field, they may also not show any row at all and so they are not considered by the system as an EC user:


     6.jpg

 

If your impacted user is not an EC user as seen above, to correct this you will need to carry out the imports again in the correct order as per article: 2080146 - Employee Central - Employee Data Import Steps - Creating Users via Imports

See Also

  • 2080146 - Employee Central - Employee Data Import Steps - Creating Users via Imports
  • 2092931 - Employee Central: Some users do not Synchronize via HRIS Sync and do not appear in Ad Hoc and ORD Reports (IS_EC_SYSTEM_OF_RECORD) 
  • 2319432 - Few users' records are present in "Personal Information" but are missing in "Global Job Information".
  • 2366537 - Employee Central views no longer available in My Employee Files for some users after b1608 release
  • 2470903 - How to use "Effective From" and "Effective To" filters to obtain historical/future records - Integration Center

Keywords

IS_EC_SYSTEM_OF_RECORD, isECRecord, isECRecord Boolean, ec user, integration center, none ec user, Integration Center , KBA , LOD-SF-EC-EMP , Employment Information (Employment Details) , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , LOD-SF-EC-HRS , HRIS Sync , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions