SAP Knowledge Base Article - Public

2581244 - Users do not Have Access to Report - Canvas / Online Report Designer - ORD user created manually

Symptom

  •  Report Canvas not available for few users in Report center.
  •  User has full permission but still unable to create Canvas report through Report Center

Environment

SAP Successfactors HXM Suite

Reproducing the Issue

  1.  Go to Report Center Page and click New.
  2.  Report Canvas is missing

Cause

  •  This could be due to the User record available under User Maintenance missing some data or have incorrect data which are required for SSO to work.
  •  For Example: the email id is not available or not in sync with Bizx email id, Person GUID is not correct (00000000-0000-0000-0000-000000000000).

Resolution

To resolve the issue you need to delete the user record from User Maintenance and ask the user to access the Report center/Analytics again.
As soon as the user accesses the Report center/Analytics page, a new user record will get created under User Maintenance with correct information and Report Canvas/Analytics will be accessible.

See Also

Other possible causes and fixes:
2796673 - Report Canvas is unavailable in Report Center

Related articles:
2397730 - How to Change User Role assignment via the Analytics Admin - User maintenance
2151880 - Online Report Designer (ORD) Admin Features
2762935 - Online Report Designer (ORD) / Report - Canvas Functional Permissions migration to RBP

Keywords

Canvas, Report, missing, not, appearing, user, unable, able, create, report, ord, Online Report, Designer, Analytics, Center, error , KBA , LOD-SF-ANA-RCT , Report Centre , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM Suite all versions