SAP Knowledge Base Article - Public

2579550 - Advanced Search for Leads Using Country Field Shows Results from Not Selected Country

Symptom

Your search for Leads using Country field is showing results from other countries than the one selected.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Login in the system.
  2. Go to the Sales work center.
  3. Go to the Leads view.
  4. Click in the Magnifying Glass icon to open the advanced search.
  5. Select 'All' in the dropdown menu.
  6. On Country field enter ABC (where ABC stands as the country selected).
  7. Click in the Go button (or hit 'Enter' on the keyboard).

You notice in the search results Leads from other countries than the one selected in the step 6 above.

Cause

The search results shows the lead account country main address. The country selected as search criteria is in the other addresses maintained for the lead account.

Resolution

This is the current system standard behavior. If you need to show the lead account non-main country addresses in the leads search, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
b) If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page

An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

Lead Country Search Account Address , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer all versions