SAP Knowledge Base Article - Public

2576472 - Not able to change the "From" field when using the SuccessFactors Application

Symptom

  • I can't change use my work email to send emails from the SF App.
  • Trying to change the from field when sending an email.
  • From field auto populates with personal email instead of secure email.
  • I do not have the option to send email from my work email.

Environment

  • BizX Platform
  • Mobile Framework
  • Apple iOS

Reproducing the Issue

  1. Login using SF App on iOS device.
  2. Search for user you would like to send email to.
  3. Click on his name to bring you to the Org Chart.
  4. Go to the users profile.
  5. Click on his email address to send email.
  6. This brings you to the default mail app used on the device (Mail).
  7. The "From:" field is auto populated with the email accounts installed to the device.
  8. Users cannot choose a secure work mail.

Cause

When the user clicks on the email address, iOS opens the default mail app Mail (and not any other non-native email app installed on the device).

Resolution

  • This is Expected Behaviour.
  • iOS does not allow to change the default mail app for their device.

Keywords

SF, App, Email, From, iOS, Iphone, iPad, Citrix Mail Secure, VMware's Boxer, Mail, MOB-20056, Default , KBA , LOD-SF-FWK-MOB , Mobile Framework , Problem

Product

SAP SuccessFactors HCM Suite all versions