SAP Knowledge Base Article - Public

2572808 - Update the SAP CPI(HCI) Keystore With New Certificates

Symptom

The Certificates within CPI need to be updated.

Environment

CPI Tenant (Version 2.29) and Above.

Reproducing the Issue

N/A

Cause

You are required to update Inbound/Outbound Certificates.

Resolution


For version 2.29 tenants and Above, adding certificates to the Key store can now be done from the customer.

Please see the following SAP Note: ##2469460.

The self-service procedure is described in the product documentation and explained in detail in the following blogs:

https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-US/2dc8942e02de4be59bd2afaa3bfdc591.html
https://blogs.sap.com/2017/06/19/cloud-integration-keystore-monitor-now-available-for-tenant-administrator/
https://blogs.sap.com/2017/06/19/cloud-integration-how-to-setup-secure-outbound-http-connection-using-keystore-monitor/

See Also

https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-US/2dc8942e02de4be59bd2afaa3bfdc591.html
https://blogs.sap.com/2017/06/19/cloud-integration-keystore-monitor-now-available-for-tenant-administrator/
https://blogs.sap.com/2017/06/19/cloud-integration-how-to-setup-secure-outbound-http-connection-using-keystore-monitor/

Keywords

Web Certificate HCI CPI CRM ERP Certificate Management Keystore 2.x version 1.x version import certificate outbound communication , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To

Product

SAP Cloud for Customer 1802 ; SAP Hybris Cloud for Customer 1711