Symptom
When entering a Serial ID in the Products facet when creating a Ticket, you get the error message: 'Serial ID XYZ is Not Unique. Please Enter a Product'.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
-
Go to the Service workcenter.
- Go to the Tickets view.
- Open or create any Ticket of type Service Request.
- Go to the Products facet.
- Enter the Serial ID XYZ in the field Serial ID (XYZ stands for a Serial ID that is used for multiple products).
Result: You get the error message: 'Serial ID XYZ is Not Unique. Please Enter a Product'.
Cause
The Serial ID XYZ is used for multiple products and a technical limitation in the system for duplicate Serial IDs causes this error to appear. As a consequence, the value help of the Serial ID field does not return the uniquely selected record of the Product and the Serial ID.
Resolution
Please also add the relevant Product to the Products facet in the Ticket:
- Go to the Service workcenter.
- Go to the Tickets view.
- Open any ticket of type Service Request.
- Go to the Products facet.
- Enter the Product ABC in the Product field (ABC stands for a Product with the SErial ID XYZ).
- Enter the Serial ID XYZ in the field Serial ID.
Keywords
Ticket, Serial ID, Product, Not Unique, Please Enter a Product , KBA , LOD-CRM-SRP , Service Request Processing , How To