SAP Knowledge Base Article - Public

2563412 - User search results not coming in alphabetical order

Symptom

The user search results are not being displayed in alphabetical order when trying to assign items.

Environment

SuccessFactors LMS

Reproducing the Issue

1. In the Learning Administration page, go to the item you would like to assign.

2. In the "Actions" menu, click assign.

3. The "User Needs Management" window will open. Click "add one or more from list."

1.png

4. Click "Search"

5. The results are not being displayed in alphabetical order:

2.png

Cause

LMS will sort the results in the same order of the main User search page. Go to Users > Users and perform a search.

3.png

Notice that in the above screenshot, the results are order by UserID an you can also order it by OrganizationID and DomainID.

If in your last search you ordered the results by UserID, they will also be ordered by UserID when you try to assign an Item.

Resolution

It's not possible to order the results in the screen to select the users you want to assign items.

You will need to go back to the main user search page and order the results in the same way you would like it to be displayed in the screen to assign items.

To order the results by User Name, you can add or remove a column from the search results by clicking the "Field Chooser" button. This will reset the configuration and the search will display the results ordered by the User Name again.

Another option is to allow the search to be ordered by User Name.

See Also

2460821 - How to enable UserName sort in the user search results - LMS

Keywords

user search, order by, alphabetical order , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions