SAP Knowledge Base Article - Public

2562016 - User Update Run Log Displays Following Warning Message: View ABC can't be assigned since no restrictions could be determined

Symptom

User Update Run log displays following warning message: View ABC can't be assigned since no restrictions could be determined (ABC represent the name of the work centre view).

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

Prerequisites:

You have already created a Business Role, assigned it to a Business User and used the Update Users functionality to trigger the User Update Run.

  1. Go to the Administrator work centre.
  2. Select the General Settings view.
  3. Click the Business Roles hyperlink, under the Users section.
  4. Select and open the relevant business role.
  5. Click the View All button.
  6. Click the Assigned Users button.
  7. Choose the Show Background Runs option.
  8. Click the Display Log button.
  9. Select the Results facet.

Here you see following warning message displayed: View ABC can't be assigned since no restrictions could be determined.

Cause

Depending on the chosen restriction rules the system searches, if the Organisation to which the User is assigned is marked as Sales or Service.

If the flag is missing the work centre view will not be assigned to the user.

Resolution

You have to use the following steps:

  1. Go to the Administrator work centre.
  2. Select the General Settings view.
  3. Click the Org Structures hyperlink, under the Company section.
  4. Select and open the relevant org structure.
  5. Select the Functions facet.
  6. Click the Edit button.
  7. Set the relevant flags.
  8. Save the changes.

Keywords

User Update Run, Work centre view, Access Restricion , KBA , view abc can't be assigned since no rest , access restricion , user update run , work centre view , SRD-CC-IAM , Identity & Access Management , How To

Product

SAP Cloud for Customer all versions ; SAP HYBRIS C4C CORE all versions