SAP Knowledge Base Article - Public

2560265 - Changing the Owner of a Lead does not Generate Notifications for the New Owner

Symptom

The new owner of a lead does not receive a notification when the owner of the lead is changed.

Reproducing the Issue

 

  1. Go to the Sales work centre.
  2. Select the lead ABC (ABC represents the ID of the lead).
  3. Open the lead and enter edit mode.
  4. Change the Owner to employee DEF (DEF represents the name of the owner).
  5. Employee DEF receives no notification about the change.

Cause

Notifications are not automatically generated in this case. This is standard system behaviour.

Resolution

Possible workaround: It is possible to create a workflow rule that will generate a notification for the newly assigned owner:

  1. Go to the work centre Administrator.
  2. Select the Workflow rule view and select New.
  3. Set the Business Object: Leads and Timing: On Every Save.
  4. Set the condition as: Field: Owner. Check the Value Before Object Change checkbox. Compare Operator: Not equal to. With: Field Owner and select Next.
  5. Navigate to the Recipient Determination and select the value help.
  6. Choose the Marketing responsible Employee as this is the Owner.
  7. This will send a notification to the new owner.

Keywords

workflow lead notifications owner , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Hybris Cloud for Customer 1711 ; SAP LE APPL.PLATFORM 1711