2559649 - Adding Attachments to Workflow Created E-mail

SAP Knowledge Base Article - Public

2559649 - Adding Attachments to Workflow Created E-mail

Symptom

You notice that the Workflow Rule created to trigger E-mail notifications is not adding attachments in the E-mails.

Reproducing the Issue

1. Go to the Administrator Work Center.

2. Go to Workflow Rules View.

3. Create a new Rule by clicking on New.

4. When you reach 3 Define Actions, select Rule Type E-mail.

5. Still in 3 Define Actions, tick the box Add Attachment.

6. Finalise and run the Rule.

Result: The attachment was not included in the notification e-mail.

 

Cause

This is the current system behaviour.

Resolution

Beginning with 1708, this feature requires an additional PDI enhancement that implements the logic to collect the documents and attach them to the e-mail. (ExitForGettingWorkflowAttachment)

Keywords

E-mail attachment, workflow attachment, workflow rule e-mail attachment , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711