SAP Knowledge Base Article - Public

2554935 - ItemEvaluationAssignmentNotification - Survey Direct Link tag without hyperlink

Symptom

When running the ItemEvaluationAssignmentNotification, where the Survey Direct Link tag is in it, the survey link does not come in the notification.

Environment

Learning Management System

Reproducing the Issue

In the LMS admin side, click on:

   1. Learning >
   2. Items >
   3. search for the desired item and access it >
   4. click on "Send Notification" from the Actions box >
   5. advance until step 4, add or remove the desired users that will receive the notification >
   6. advance until step 5, click on the magnifying glass from the option "Email Template" >
   7. select the ItemEvaluationAssignmentNotification template >
   8. click on "Send Notification" >
   9. the survey link does not come in the notification.

Cause

It happens because sending the notification through those steps would configure an Ad Hoc notification. The user tags are the ones supported to work when an Ad Hoc notification is sent. Other tags will appear in the Ad Hoc notification as text or will not appear. Take a look at the KBA 2330530 - LMS Notifications Knowledge Support and Tips for additional information related to it.

Resolution

To have the notification tested or sent as desired, in the LMS admin side, click on:

   1. System Admin >
   2. Automatic Processes >
   3. Evaluation Synchronization >
   4. schedule it to run on the date and time desired >
   5. the survey link does not come in the notification.

See Also

KBA 2330530 - LMS Notifications Knowledge Support and Tips

Keywords

ItemEvaluationAssignmentNotification, Survey Direct Link, tag, hyperlink, notification, blank, text , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions