2552449 - Competency description is not synced after Competency Connector running successfully

SAP Knowledge Base Articles - public

2552449 - Competency description is not synced after Competency Connector running successfully


We are using Competency Connector to sync Competencies from SF BizX to LMS system. We've done all required configurations and the connector is also executed successfully, however when checking them in Performance>Competencies>Search, we found all competencies have blank description, it seems the Competency IDs are synced correctly, however descriptions are all missing..


By checking CONNECTORS property file in System Configuration>CONNECTORS, we found the following configuration is presen


With this setting, LMS system will map all zh_CN locale competencies from BizX side to English locale competencies on LMS side. Thus if you have only zh_CN locale competencies as source data from BizX side, LMS admin will only see those competency data under English locale. If the LMS admin's locale preference happens to be Chinese, he will not able to see competency descriptions correctly. Under such circumstance, if we change the particular LMS admin's preferred locale to English, back to check Performance>Competencies, you will see Chinese competency descriptions displaying there.


Go to System Admin>Configuration>System Configuration>CONNECTORS,

Change above mentioned property to:



(Note "competency.sfcompetency.field.transform.data.LOCALE.English=en,en_US" is required by default)

Save it and run the Competency Connector once again.

See Also

 2173658 - How to map BizX Locale to LMS Locale via User SF Connector-LMS


KBA , LOD-SF-LMS-CON , Connectors , Problem


SAP SuccessFactors Learning all versions