2546182 - Item Usage no longer shows data for survey for an item

SAP Knowledge Base Article - Public

2546182 - Item Usage no longer shows data for survey for an item

Symptom

Checking Item Usage tab in the Survey does not show the data gathered for a particular survey (for all items or for only one particular item).

Environment

Success Factors Learning Management System (LMS)

Reproducing the Issue

  1. Go to Learning->Questionnaire Surveys
  2. Find the desired Survey and click in View or Edit
  3. Go to Item Usage
  4. The data associated with the Survey is no longer available (for all items or for only one particular item)

Cause

  • Editing a survey: you may lose all the data associated to that particular survey, this being relative to all answers and responses for that particular survey.
  • Changing the Survey associated with an item: being by removing the survey or by replacing it with a new survey, the data associated to that survey for the item will be lost. There will be no more records of the answers and responses of that survey for that item.

Resolution

As a workaround, to be able to change the evaluation (survey) associated with an item, it is needed to revise that item before changing the survey.

For clarification, the answers and response for a survey are associated to a particular revision of an item therefore, changing the survey in the revision 2 of an item doesn't impact the data stored for the answers and responses provided for the revision 1 of that item.

See Also

2272618 - Evaluation Surveys not being added to Items via Item Connector

2546172 - Changing an Evaluation on an Existing Item

Keywords

Blank, No data, Data Missing, Survey, Item Usage, Answers, Responses , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , LOD-SF-LMS-ITE , LMS Items , How To

Product

SAP SuccessFactors Learning all versions