SAP Knowledge Base Article - Public

2546069 - You Cannot Add Products To Sales Orders After Adapting The Screen

Symptom

You cannot add products to a Sales Order after adapting the screen.

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Orders view.
  3. Open a Sales Order.
  4. Go to Products tab.
  5. Click on Quick Add Products button.
  6. Click on Product Lists button.
  7. Select the products you want to add.

The Add Products button did not change its counter and no products are added when you click it.

Cause

You have removed the check box column next to Product List column.

Resolution

If you wish to remove the check box column and still be able to add products from the Product List, you need to mark off the Visible flag through Adaptation Mode, instead of removing it completely.

  1. Go to the Sales work center.
  2. Go to Sales Orders view.
  3. Open a Sales Order.
  4. Go to Products tab.
  5. Click on Adapt button.
  6. Click on Edit Master Layout.
  7. Click on Quick Add Products button.
  8. Click on Product Lists button.
  9. Hover the cursor over the Check box column.
  10. Click on Change properties button.
  11. Mark the Visible flag off.
  12. Click on Apply.
  13. Select the products you want to add.
  14. Click on Add Products.

Keywords

KBA , SRD-CC-FED , Feeds , How To

Product

SAP Cloud for Customer 1802 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711 ; SAP LE APPL.PLATFORM 1708 ; SAP LE APPL.PLATFORM 1711 ; SAP LE APPL.PLATFORM 1802