SAP Knowledge Base Article - Public

2544696 - We couldn't connect to your (source) system / Failed to connect to (source) system creating / using a live data connection in SAP Analytics Cloud *** Collective KBA ***

Symptom

You are creating / using a live data connection in SAP Analytics Cloud and the following error occurs:

  • failed to connect to (source) system
  • We couldn't connect to your (source) system.

Environment

  • SAP Analytics Cloud (Enterprise)
  • Live data sources: SAP HANA (On-premise), SAP HANA Service for BTP, SAP HANA Cloud, SAP S/4HANA, SAP BW, SAP BW/4HANA, BPC Embedded, etc.

Cause

This message appears in Live connections when you cannot establish a connection to a live data source.

Resolution

There are multiple data sources and methods to create a live connection, follow the steps that best describe your scenario.

Using Direct Connection (CORS)

When you select Direct Connection, your browser is connecting directly to SAP Analytics Cloud and your data source: HANA, BW, S/4HANA, Live Universe Connection, etc. using two different requests. This type of connection requires Cross Origin Resource Sharing (CORS) to be enabled in your datasource.

These are some of the possible causes:

  • HTTPS Certificate: the certificate used by your data source is not trusted by your browser.
    Test this as follows:
    i. Open a new browser tab and connect directly to the data source. For example, for HANA you can use:
    https://<xs-host:port>/sap/bc/ina/service/v2/GetServerInfo.
    ii. Verify that the certificate is automatically trusted.
    iii. You should not see any warnings or be requested to accept exceptions.
    iv. See article 2482807 - Secure HTTPS Browser configuration using Live Data Connections (CORS) in SAP Analytics Cloud.
  • Authentication method: is not correctly configured in your data source.
    i. You may have selected SAML SSO in your connection as an authentication method, but the current SAP Analytics user does not exist in the data source (S/4HANA or HANA).
    ii. The user or connection (InA) does not allow SAML as an authentication method. To verify it, open a new tab in your browser and use the URL indicated in the previous example (HANA, S/4HANA, etc.). It should open without prompting for a new authentication.
    iii. You will find notes on how to perform this action in the product’s documentation. See article KBA 2545434 with more information on SAML SSO settings for SAP HANA and KBA 2487567 - Troubleshooting SAML assertions when configuring SAML SSO in SAP Analytics Cloud
  • CORS configuration: After verifying the two previous steps, you may still have problems if the server-side (backend) CORS configuration is incorrect.
    i. To verify that this is the case, open Chrome Developer Tools and check that the Console shows an error similar to this:

    https://<xs-host:port>/sap/bc/ina/service/v2/GetServerInfo?timestamp=1507241400382: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://yoursapanalytics.cloud' is therefore not allowed access
    OR
    Access to XMLHttpRequest at '' from origin '' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

  • ii. If you see that error in the console, it means that your data source has incorrect CORS settings, rejecting the request from your SAP Analytics Cloud system to get data in the same page.
    iii. Verify your data source CORS settings.
  • Other CORS errors: CORS errors can also be caused due to issues with the SameSite Cookie, or Private Network Access (PNA) Headers, which can be checked below;
    • SameSite Cookie Troubleshooting - 2890576 - After Google Chrome 80 update, Live Data Connections are no longer working in SAP Analytics Cloud (SAC) & SAP Digital Boardroom
    • Private Network Access Troubleshooting3205694 - SAP Analytics Cloud (SAC) stories (charts and tables) connected to live data sources fail due to the private network authentication (PNA) specification using Google Chrome and Microsoft Edge versions 104 and later
  • SAP HANA upgrade/EPM library upgrade (SAP HANA ONLY)
    CORS settings could be easily removed after a HANA upgrade. CORS configuration steps must be repeated after every SAP HANA or SAP EPM library upgrade.
    Refer to: Live Data Connection to SAP HANA Using a Direct Connection and SSO.

Using a Tunnel Connection (Advanced Features)

When a Tunnel connection is used, the Cloud Connector placed within your corporate network scenario, will connect to your datasource, allowing Stories using this Connection, to be accessed from any network.

To troubleshoot Tunnel / Advanced Features connections, please refer to the KBA below;

  • 2987799 - [Best Practice] How to troubleshoot advanced features based on Live Data Connection to SAP BW in SAP Analytics Cloud (SAC)

Using an SAP HANA Service for BTP connection (BTP was formerly named the SAP Cloud Platform)

This is similar to the previous scenario. You can only experience this problem if:

  • CORS: you have selected authentication method None but you have not correctly configured CORS in the HANA XS engine.
  • SAML single sign-on: the user does not exist in HANA or the SAML configuration for HANA is incorrect.
    For more details on how to enable SAML SSO to HANA in SAP Cloud Platform, review this blog SAP Analytics Cloud: Live Data Connection to HANA in SAP Cloud Platform With SSO.
  • Username requires to change password. If you selected the box on expiration of the password and the user must change the password on the next logon, you may see the following error if you open Chrome Developer tools in your browser:
    Status Code 403. You can test trying to connect directly to your HANA in SAP CP and verify if you are prompted to change your password.

Using a Reverse Proxy (deprecated)

This applies to different on-premise data sources: HANA, S/4HANA, BW, SAP Universe Live Connection, etc.

You will need to examine the logs of your reverse proxy to understand why the connection failed. You still can have the same scenarios described for Direct Connection: CORS configuration and incorrect SAML SSO method.

  • Certificate: your reverse proxy may not trust the certificate sent by your data source if you are connecting to it using HTTPS. To verify this is the issue, you can test simply using HTTP connection instead in your reverse proxy configuration and verify it works correctly. You can either resolve the trust issue importing the certificate authority or configure your reverse proxy to ignore certificate warnings as indicated in KBA 2391607 for Apache.
  • Path or settings: if you have incorrectly configured parameters in your reverse proxy, SAP Analytics Cloud can't connect or authenticate. To verify it, open a new tab in your browser and connect directly to the path used for your data source. For example, for HANA:
    https://<your_reverse_proxy>/<PATH_for_HANA>/sap/bc/ina/service/v2/GetServerInfo

Live Data connection to SAP Universe

Many of the requirements for HANA also apply for Live connections to SAP Universes. See article 2527393 - SAP Analytics Cloud Live Data Connection to SAP Universes via SAP BOE Live Data Connect.

See Also

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Keywords

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Failed to connect to <> system. Possible causes: SSL certificate untrusted, network error. (Admin)
Failed to connect to <> system. Possible causes: The SSL certificate is not trusted, or a network error occurred.
Failed to connect to <> system. Please contact your administrator to check possible causes: SSL certificate untrusted, network error. (end user)
Failed to connect to <> system. Please ask your administrator to check that your SSL certificate is trusted, and that your network is working correctly.
Failed to connect to <> system. Possible causes: CORS settings, incorrect credentials. (Admin)
Failed to connect to system. Possible causes: You are using the wrong credentials, or CORS is not configured correctly.
Failed to connect to <> system. Please contact your administrator to check possible causes: CORS settings, incorrect credentials. (end user)
Failed to connect to <> system. Please ask your administrator to check you are using the right credentials, and that CORS is configured correctly.
Failed to connect to <> system. Possible causes: CORS settings, third-party cookies blocked. (Admin)
Failed to connect to <> system. Possible causes: third-party cookies are blocked, or CORS is not configured correctly.
Failed to connect to <> system. Please contact your administrator to check possible causes: CORS settings, third-party cookies blocked. (End User)
Failed to connect to <> system. Please ask your administrator to check that third-party cookies are not blocked, and that CORS is configured correctly.
Failed to connect to <> system. More information can be found on the troubleshooting page. (Admin)
Failed to connect to <> system. For more information, see our troubleshooting page.
Failed to connect to <> system. Please contact your administrator to check possible causes. (End User)
Failed to connect to <> system. Please ask your system administrator to investigate.
We couldn't connect to your HANA system. Possible causes: Third- party cookies are blocked, or CORS is not configured correctly. For more information, see our troubleshooting page.
We couldn't connect to your BW system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
We couldn't connect to your HANA system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
We couldn't connect to your BW system. Please ask your administrator to check that your SSL certificate is trusted, and that your network is working correctly.
We couldn't connect to your HANA system. Please ask your administrator to check that your SSL certificate is trusted, and that your network is working correctly.
We couldn't connect to your S/4 HANA system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
We couldn't connect to your S/4HANA system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
We couldn't connect to your BPCE system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
We couldn't connect to your BPCE system. For more information, see our troubleshooting page.
We couldn't connect to your BPCE system. Please ask your administrator to check that your SSL certificate is trusted, and that your network is working correctly.
我们无法连接到你的 BW 系统。可能的原因:SSL 证书不受信任;发生了网络错误。有关更多信息,请参阅故障排除页面
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Product

SAP Analytics Cloud 1.0